Counter-Strikle Multiplayer unstable

Incident Report for BLAST TV

Resolved

We have deployed a captcha, to minimize the automated load on the service, and it is performant again.
Posted Mar 28, 2025 - 11:42 CET

Investigating

We are getting massive load on the game, so it might be a bit unreliable currently.
Posted Mar 27, 2025 - 15:30 CET
This incident affected: BLAST.TV (Mini games).