Major outage

Incident Report for BLAST TV

Resolved

The incident has been resolved.
Posted Mar 22, 2026 - 16:20 CET

Monitoring

Our CMS provider has identified and solved the issue. We are monitoring to make sure everything is back up.
Posted Mar 22, 2026 - 16:06 CET

Update

We are continuing to investigate this issue.
Posted Mar 22, 2026 - 16:04 CET

Investigating

Our CMS system is experiencing issues, so the site is currently down. We are investigating
Posted Mar 22, 2026 - 15:41 CET
This incident affected: BLAST.TV (Site).